summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-advanced-reboot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-advanced-reboot/Makefile')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index 4c0e793659..1f0f030006 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -1,19 +1,29 @@
-# Copyright 2017-2018 Stan Grishin (stangri@melmac.net)
-# This is free software, licensed under the GNU General Public License v3.
+# Copyright 2017-2024 MOSSDeF, Stan Grishin (stangri@melmac.ca).
+# This is free software, licensed under AGPL-3.0-or-later.
include $(TOPDIR)/rules.mk
-PKG_LICENSE:=GPL-3.0-or-later
-PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
-PKG_VERSION:=1.0.1-11
+PKG_NAME:=luci-app-advanced-reboot
+PKG_LICENSE:=AGPL-3.0-or-later
+PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
+PKG_VERSION:=1.0.1
+PKG_RELEASE:=13
LUCI_TITLE:=Advanced Linksys Reboot Web UI
-LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
+LUCI_URL:=https://github.com/stangri/luci-app-advanced-reboot/
LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot supported Linksys and ZyXEL routers to\
an alternative partition. Also provides Web UI to shut down (power off) your device. Supported dual-partition\
routers are listed at https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
LUCI_DEPENDS:=+luci-base +jshn
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+ .
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+endef
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature