summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-advanced-reboot/Makefile
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2024-09-22 17:45:28 +0000
committerStan Grishin <stangri@melmac.ca>2024-09-22 17:45:54 +0000
commitb884bf4f47e5bea487a2f0962976bd373ffa727f (patch)
tree58fb074551c0b41b2e6377f0833d0a4aa2d34f47 /applications/luci-app-advanced-reboot/Makefile
parentc360e3742c79cb6276f39ed769a3a0fc9dda87da (diff)
luci-app-advanced-reboot: update to 1.0.1-13
* update copyright * update license * split version string into PKG_VERSION and PKG_RELEASE for APK compatibility * update upstream URL link * add menuconfig title/version info * update README * add support for: * Linksys MX4200v1 (Thanks @innovara) * Linksys MX4200v2 (Thanks @innovara) * Linksys MX4300 (Thanks @PIPIPIG233666) Signed-off-by: Stan Grishin <stangri@melmac.ca>
Diffstat (limited to 'applications/luci-app-advanced-reboot/Makefile')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index 4c0e793659..1f0f030006 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -1,19 +1,29 @@
-# Copyright 2017-2018 Stan Grishin (stangri@melmac.net)
-# This is free software, licensed under the GNU General Public License v3.
+# Copyright 2017-2024 MOSSDeF, Stan Grishin (stangri@melmac.ca).
+# This is free software, licensed under AGPL-3.0-or-later.
include $(TOPDIR)/rules.mk
-PKG_LICENSE:=GPL-3.0-or-later
-PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
-PKG_VERSION:=1.0.1-11
+PKG_NAME:=luci-app-advanced-reboot
+PKG_LICENSE:=AGPL-3.0-or-later
+PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
+PKG_VERSION:=1.0.1
+PKG_RELEASE:=13
LUCI_TITLE:=Advanced Linksys Reboot Web UI
-LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
+LUCI_URL:=https://github.com/stangri/luci-app-advanced-reboot/
LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot supported Linksys and ZyXEL routers to\
an alternative partition. Also provides Web UI to shut down (power off) your device. Supported dual-partition\
routers are listed at https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
LUCI_DEPENDS:=+luci-base +jshn
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+ .
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+endef
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature