summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-advanced-reboot
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-advanced-reboot')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile22
-rw-r--r--applications/luci-app-advanced-reboot/README.md4
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4200v1.json14
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4200v2.json14
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4300.json14
5 files changed, 60 insertions, 8 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index 4c0e793659..1f0f030006 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -1,19 +1,29 @@
-# Copyright 2017-2018 Stan Grishin (stangri@melmac.net)
-# This is free software, licensed under the GNU General Public License v3.
+# Copyright 2017-2024 MOSSDeF, Stan Grishin (stangri@melmac.ca).
+# This is free software, licensed under AGPL-3.0-or-later.
include $(TOPDIR)/rules.mk
-PKG_LICENSE:=GPL-3.0-or-later
-PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
-PKG_VERSION:=1.0.1-11
+PKG_NAME:=luci-app-advanced-reboot
+PKG_LICENSE:=AGPL-3.0-or-later
+PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
+PKG_VERSION:=1.0.1
+PKG_RELEASE:=13
LUCI_TITLE:=Advanced Linksys Reboot Web UI
-LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
+LUCI_URL:=https://github.com/stangri/luci-app-advanced-reboot/
LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot supported Linksys and ZyXEL routers to\
an alternative partition. Also provides Web UI to shut down (power off) your device. Supported dual-partition\
routers are listed at https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
LUCI_DEPENDS:=+luci-base +jshn
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+ .
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+endef
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-advanced-reboot/README.md b/applications/luci-app-advanced-reboot/README.md
index a0fd20c9ef..11df6a7380 100644
--- a/applications/luci-app-advanced-reboot/README.md
+++ b/applications/luci-app-advanced-reboot/README.md
@@ -1,3 +1,3 @@
-# Advanced Reboot Web UI (luci-app-advanced-reboot)
+# README
-README has been moved to [https://docs.openwrt.melmac.net/luci-app-advanced-reboot/](<https://docs.openwrt.melmac.net/luci-app-advanced-reboot/>).
+Documentation for this project is available at [https://docs.openwrt.melmac.net/luci-app-advanced-reboot/](https://docs.openwrt.melmac.net/luci-app-advanced-reboot/).
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4200v1.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4200v1.json
new file mode 100644
index 0000000000..01213849aa
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4200v1.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "Linksys",
+ "deviceName": "MX4200v1",
+ "boardNames": [ "linksys,mx4200v1" ],
+ "partition1MTD": "mtd21",
+ "partition2MTD": "mtd23",
+ "labelOffset": 192,
+ "bootEnv1": "boot_part",
+ "bootEnv1Partition1Value": 1,
+ "bootEnv1Partition2Value": 2,
+ "bootEnv2": null,
+ "bootEnv2Partition1Value": null,
+ "bootEnv2Partition2Value": null
+}
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4200v2.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4200v2.json
new file mode 100644
index 0000000000..44e8d3c80d
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4200v2.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "Linksys",
+ "deviceName": "MX4200v2",
+ "boardNames": [ "linksys,mx4200v2" ],
+ "partition1MTD": "mtd21",
+ "partition2MTD": "mtd23",
+ "labelOffset": 192,
+ "bootEnv1": "boot_part",
+ "bootEnv1Partition1Value": 1,
+ "bootEnv1Partition2Value": 2,
+ "bootEnv2": null,
+ "bootEnv2Partition1Value": null,
+ "bootEnv2Partition2Value": null
+}
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4300.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4300.json
new file mode 100644
index 0000000000..8692c6d2b2
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-mx4300.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "Linksys",
+ "deviceName": "MX4300",
+ "boardNames": [ "linksys,mx4300" ],
+ "partition1MTD": "mtd21",
+ "partition2MTD": "mtd23",
+ "labelOffset": 192,
+ "bootEnv1": "boot_part",
+ "bootEnv1Partition1Value": 1,
+ "bootEnv1Partition2Value": 2,
+ "bootEnv2": null,
+ "bootEnv2Partition1Value": null,
+ "bootEnv2Partition2Value": null
+}