summaryrefslogtreecommitdiffhomepage
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2021-07-10 12:06:53 +0200
committerJo-Philipp Wich <jo@mein.io>2021-07-11 15:49:14 +0200
commitf5d7526152c0272044f3df55a23e29156efe463e (patch)
tree83cf37702b98e4e996586038d7ad205e8a3438cd /examples/CMakeLists.txt
parent559eff22d201f0dfa16198ae7724f173f1ea948c (diff)
examples: add libucode usage examples
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 0000000..12d32ba
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,7 @@
+FILE(GLOB examples "*.c")
+FOREACH(example ${examples})
+ GET_FILENAME_COMPONENT(example ${example} NAME_WE)
+ SET(CLI_SOURCES main.c)
+ ADD_EXECUTABLE(${example} ${example}.c)
+ TARGET_LINK_LIBRARIES(${example} libucode ${json})
+ENDFOREACH(example)