summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMikael Magnusson <mikma@users.sourceforge.net>2024-11-18 18:35:26 +0100
committerMikael Magnusson <mikma@users.sourceforge.net>2024-11-22 12:59:13 +0100
commit0badc88d7a39f431cbc53ba6be61113b1f2d638d (patch)
treeef04e31b801c36b0396d2b6683f6ecf675957c18 /CMakeLists.txt
parentc626e488ba7c1b3c5932dc887402b9ba4c320f29 (diff)
lib: add crypto.uccrypto
The module crypto.uc uses one of crypto_openssl and crypto_mbedtls to provide a cryptographic implementation to the user. The crypto_openssl module is preferred since it supports EdDSA in addition to RSA and ECDSA, which are also supported by crypto_mbedtls. Signed-off-by: Mikael Magnusson <mikma@users.sourceforge.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 727a9b8..e5a5d27 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -318,6 +318,10 @@ if(CRYPTO_OPENSSL_SUPPORT)
target_link_libraries(crypto_openssl_lib crypto)
endif()
+if(CRYPTO_MBEDTLS_SUPPORT OR CRYPTO_OPENSSL_SUPPORT)
+ install(FILES lib/crypto.uc DESTINATION share/ucode)
+endif()
+
if(UNIT_TESTING)
enable_testing()
add_definitions(-DUNIT_TESTING)