summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c7fed2d4..5d5c09a3 100644
--- a/setup.py
+++ b/setup.py
@@ -21,10 +21,19 @@ from setuptools import setup
long_description = 'Ryu is an open-sourced network operating system licensed under Apache License v2. Ryu aims to provide logically centralized control and well defined API that makes it easy for cloud operators to implement network management applications on top of the Ryu. Currently, Ryu supports OpenFlow protocol to control the network devices.'
+classifiers = [
+ 'License :: OSI Approved :: Apache Software License',
+ 'Topic :: System :: Networking',
+ 'Natural Language :: English',
+ 'Programming Language :: Python',
+ 'Operating System :: Unix',
+ ]
+
setup(name='ryu',
version='0.2',
description=("Ryu Network Operating System"),
long_description=long_description,
+ classifiers=classifiers,
keywords='openflow openvswitch openstack',
url='http://www.osrg.net/ryu/',
author='Ryu project team',