summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorFUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>2012-06-13 00:00:46 +0900
committerFUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>2012-06-15 11:23:56 +0900
commit3fafa122d45f3e5577a8f72ff14e51feb915b402 (patch)
treef50fd77bc771cec187e10e05e65378c55d9caa8d /setup.py
parent039aef28516a6175c858f19d6e7bbe99212608fb (diff)
update setup.py for PyPI
Add classifiers. Signed-off-by: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c7fed2d4..5d5c09a3 100644
--- a/setup.py
+++ b/setup.py
@@ -21,10 +21,19 @@ from setuptools import setup
long_description = 'Ryu is an open-sourced network operating system licensed under Apache License v2. Ryu aims to provide logically centralized control and well defined API that makes it easy for cloud operators to implement network management applications on top of the Ryu. Currently, Ryu supports OpenFlow protocol to control the network devices.'
+classifiers = [
+ 'License :: OSI Approved :: Apache Software License',
+ 'Topic :: System :: Networking',
+ 'Natural Language :: English',
+ 'Programming Language :: Python',
+ 'Operating System :: Unix',
+ ]
+
setup(name='ryu',
version='0.2',
description=("Ryu Network Operating System"),
long_description=long_description,
+ classifiers=classifiers,
keywords='openflow openvswitch openstack',
url='http://www.osrg.net/ryu/',
author='Ryu project team',