summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorFUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>2012-04-06 08:38:45 +0900
committerFUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>2012-04-06 08:38:45 +0900
commit711301abb3ab338e68411823e10ec40d0663d757 (patch)
tree9df20c8be0d76dd78ed4c589d9971fc3a095e9c9 /setup.py
parent382f9b3d95f05e119fd34b276ab92aca047b889f (diff)
Switch to Apache 2.0 license
To make the further integration into IaaS OSS (OpenStack and CloudStack) easier, we switch to Apache 2.0 license. ryu/app/wsapi.py is still under GPL3 or later. We replace it later. Signed-off-by: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 11 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 0952a0fc..c13850b2 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,18 @@
# Copyright (C) 2011 Nippon Telegraph and Telephone Corporation.
# Copyright (C) 2011 Isaku Yamahata <yamahata at valinux co jp>
#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, version 3 of the License.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
+# http://www.apache.org/licenses/LICENSE-2.0
#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
import os
@@ -29,7 +30,7 @@ setup(name='ryu',
url='http://www.osrg.net/ryu/',
# author='',
author_email='ryu-devel@lists.sourceforge.net',
- license='GPL v3 only',
+ license='Apache License 2.0',
packages=find_packages(),
scripts=['bin/ryu-manager',
'bin/ryu-client'],