summaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorYoshihiro Kaneko <ykaneko0929@gmail.com>2014-06-18 15:23:01 +0900
committerFUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>2014-06-19 08:41:51 +0900
commit03731ad04cab7746e095c44934fbdee3f1134ea0 (patch)
treea91194fbb592815448a26cf56a358a60b6d24877 /debian/rules
parentcc6dcbabaa99c77e49fabf52445d2741fcaa7676 (diff)
package: add python-ryu-doc
This patch adds python-ryu-doc package which contains the HTML documentation generated from doc/. Also updates the man pages in doc/source/man/. Signed-off-by: Yoshihiro Kaneko <ykaneko0929@gmail.com> Signed-off-by: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 15 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index fa1ae9f4..a854715e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,10 +11,18 @@ export DH_OPTIONS
%:
dh $@ --with python2
-override_dh_install:
- txt2man -d 'June 2014' -t ryu-manager -v "Ryu Manager's Manual" -s 8 < debian/ryu-manager.8.txt > debian/ryu-manager.8
- txt2man -d 'June 2014' -t ryu -v "Ryu Command's Manual" -s 8 < debian/ryu.8.txt > debian/ryu.8
- dh_install --fail-missing -X/usr/etc -X/usr/bin/quantum
+override_dh_installman:
+ cd doc; \
+ make man; \
+ cp build/man/* ../debian/
+ dh_installman
+
+override_dh_auto_build:
+ dh_auto_build
+ mkdir -p debian/html
+ cd doc; \
+ make html; \
+ cp -r build/html/* ../debian/html/
override_dh_installinit:
dh_installinit --no-start --name=ryu
@@ -22,3 +30,6 @@ override_dh_installinit:
override_dh_installlogrotate:
dh_installlogrotate --name=ryu
+override_dh_auto_clean:
+ rm -rf html
+ dh_auto_clean