diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -86,7 +86,10 @@ setup( "Programming Language :: Python :: 3.9", ], # TODO 3.0: remove bcrypt, pynacl and update installation docs noting that - # use of the extras_require(s) is now required for those + # use of the extras_require ("paramiko[ed2559]") is now required for those + # TODO 3.0: alternately, given how prevalent ed25519 is now, and how we use + # invoke for (increasing) subproc stuff, consider making the default flavor + # "full" and adding a "minimal" or similar that is just-crypto? install_requires=["bcrypt>=3.1.3", "cryptography>=2.5", "pynacl>=1.0.1"], extras_require=extras_require, ) |