diff options
author | Jeff Forcier <jeff@bitprophet.org> | 2021-10-01 15:09:43 -0400 |
---|---|---|
committer | Jeff Forcier <jeff@bitprophet.org> | 2021-10-01 15:09:43 -0400 |
commit | a5157531f3811f3ff48f15355bbc29b23a0b607b (patch) | |
tree | 482d65befff4aa41b80be447f5f416ce8742fb2e /setup.py | |
parent | e9c2005750a0d95a7cc9a100e1edeb3bfc2a984a (diff) |
Use README for long description like other projects
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 19 |
1 files changed, 9 insertions, 10 deletions
@@ -24,16 +24,15 @@ if sys.platform == "darwin": setup_helper.install_custom_make_tarball() -longdesc = """ -This is a library for making SSH2 connections (client or server). -Emphasis is on using SSH2 as an alternative to SSL for making secure -connections between python scripts. All major ciphers and hash methods -are supported. SFTP client and server mode are both supported too. - -To install the development version, ``pip install -e -git+https://github.com/paramiko/paramiko/#egg=paramiko``. -""" +text = open("README.rst").read() +long_description = """ +To find out what's new in this version of Paramiko, please see `the changelog +<https://www.paramiko.org/changelog.html#{}>`_. +{} +""".format( + version, text +) # Version info -- read without importing _locals = {} @@ -61,7 +60,7 @@ setup( name="paramiko", version=version, description="SSH2 protocol library", - long_description=longdesc, + long_description=long_description, author="Jeff Forcier", author_email="jeff@bitprophet.org", url="https://github.com/paramiko/paramiko/", |