diff options
author | Jeff Forcier <jeff@bitprophet.org> | 2016-11-30 20:02:20 -0800 |
---|---|---|
committer | Jeff Forcier <jeff@bitprophet.org> | 2016-11-30 20:02:20 -0800 |
commit | 9aec0c6300686e571fab5405c52876e6399f92e9 (patch) | |
tree | 8521aae70c6ebe889b92cbb9db69fd632f0fed08 /setup.py | |
parent | 2a568863bb462fbae50fdd4795bf4d3e05e101bb (diff) | |
parent | 7366f965546c015c3f9e9dd1ccb8f0b7b8758dae (diff) |
Merge branch 'master' into 398-int
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 31 |
1 files changed, 10 insertions, 21 deletions
@@ -24,30 +24,15 @@ connections between python scripts. All major ciphers and hash methods are supported. SFTP client and server mode are both supported too. Required packages: - pyCrypto + Cryptography -To install the `in-development version -<https://github.com/paramiko/paramiko/tarball/master#egg=paramiko-dev>`_, use -`pip install paramiko==dev`. +To install the development version, ``pip install -e +git+https://github.com/paramiko/paramiko/#egg=paramiko``. ''' -# if someday we want to *require* setuptools, uncomment this: -# (it will cause setuptools to be automatically downloaded) -#import ez_setup -#ez_setup.use_setuptools() - import sys -try: - from setuptools import setup - kw = { - 'install_requires': [ - 'pycrypto >= 2.1, != 2.4', - 'ecdsa >= 0.11', - ], - } -except ImportError: - from distutils.core import setup - kw = {} +from setuptools import setup + if sys.platform == 'darwin': import setup_helper @@ -87,6 +72,10 @@ setup( 'Programming Language :: Python :: 3.2', 'Programming Language :: Python :: 3.3', 'Programming Language :: Python :: 3.4', + 'Programming Language :: Python :: 3.5', + ], + install_requires=[ + 'cryptography>=1.1', + 'pyasn1>=0.1.7', ], - **kw ) |