summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorJeff Forcier <jeff@bitprophet.org>2014-08-26 12:53:15 -0700
committerJeff Forcier <jeff@bitprophet.org>2014-08-26 12:53:15 -0700
commit769fbac0353d1efb4213c78f5ec22a1247e4da9d (patch)
tree4e6781297384caa2608f2493f36b80c44ef70a48 /setup.py
parent8dfc2b79cbf86e8e5fce4b7a6cedf9c4b5be706d (diff)
parent162eebf704b5111d34f430488868d3185d51ba21 (diff)
Merge branch '1.13' into 1.14
Conflicts: paramiko/__init__.py setup.py sites/www/changelog.rst
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 38e444f5..235fd0e3 100644
--- a/setup.py
+++ b/setup.py
@@ -54,9 +54,16 @@ if sys.platform == 'darwin':
setup_helper.install_custom_make_tarball()
+# Version info -- read without importing
+_locals = {}
+with open('paramiko/_version.py') as fp:
+ exec(fp.read(), None, _locals)
+version = _locals['__version__']
+
+
setup(
name = "paramiko",
- version = "1.14.1",
+ version = version,
description = "SSH2 protocol library",
long_description = longdesc,
author = "Jeff Forcier",