diff options
author | Jeff Forcier <jeff@bitprophet.org> | 2023-01-09 17:32:18 -0500 |
---|---|---|
committer | Jeff Forcier <jeff@bitprophet.org> | 2023-01-09 19:33:39 -0500 |
commit | 39f458c834def3c217a3bd2eb62cc92032e20975 (patch) | |
tree | 4f884f564d20491185190b1251c58cc6229c2410 /setup.py | |
parent | 5c4b311b6951dbfcca1206d10bcbdef1a8dda219 (diff) |
Tidy up requires/entrypoints/install docs
- Realized at this date that _moving_ Ed25519 deps behind an entrypoint
is going the wrong direction, that key type should be used _more_ now,
not _less_. I no longer even remember why folks were pissy about
pynacl/bcrypt exactly.
- We can in fact just use ed25519 from cryptography itself now, so no
more pynacl anyways (but still bcrypt)
- Twiddle install language a bit re: invoke used in more places, and
again removing the notes about ed25519 being special
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 2 insertions, 9 deletions
@@ -40,8 +40,9 @@ extras_require = { 'gssapi>=1.4.1;platform_system!="Windows"', 'pywin32>=2.1.8;platform_system=="Windows"', ], - "ed25519": ["pynacl>=1.0.1", "bcrypt>=3.1.3"], "invoke": ["invoke>=2.0"], + # TODO 4.0: remove entrypoint as irrelevant + "ed25519": [], } everything = [] for subdeps in extras_require.values(): @@ -83,19 +84,11 @@ setup( "Programming Language :: Python :: 3.10", "Programming Language :: Python :: 3.11", ], - # TODO 3.0: remove bcrypt, pynacl and update installation docs noting that - # use of the extras_require ("paramiko[ed2559]") is now required for those - # TODO 3.0: alternately, given how prevalent ed25519 is now, and how we use - # invoke for (increasing) subproc stuff, consider making the default flavor - # "full"/"all"? (probably sans gssapi which should remain optional; MAYBE - # still sans invoke as well, not everyone uses ProxyCommand or Match exec) - # TODO 3.0: remove six, obviously python_requires=">=3.6", install_requires=[ "bcrypt>=3.1.3", "cryptography>=2.5", "pynacl>=1.0.1", - "six", ], extras_require=extras_require, ) |