diff options
author | Jeff Forcier <jeff@bitprophet.org> | 2016-04-24 19:02:49 -0700 |
---|---|---|
committer | Jeff Forcier <jeff@bitprophet.org> | 2016-04-24 19:02:49 -0700 |
commit | 1c20db7aa9433a1dc2ca6331e970e95e561df8e5 (patch) | |
tree | 7011eaabb85441530ac3077e88d02c7427d48747 /setup.py | |
parent | f198a69ac50c568e4547cc2cb5025e260bc8dcfd (diff) | |
parent | 06ef0e97eaa9767c2a799d231ae28c1c86418a7d (diff) |
Merge branch '1.15' into 1.16
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 24 |
1 files changed, 7 insertions, 17 deletions
@@ -31,23 +31,10 @@ To install the `in-development version `pip install paramiko==dev`. ''' -# if someday we want to *require* setuptools, uncomment this: -# (it will cause setuptools to be automatically downloaded) -#import ez_setup -#ez_setup.use_setuptools() - import sys -try: - from setuptools import setup - kw = { - 'install_requires': [ - 'pycrypto>=2.1,!=2.4', - 'ecdsa>=0.11', - ], - } -except ImportError: - from distutils.core import setup - kw = {} + +from setuptools import setup + if sys.platform == 'darwin': import setup_helper @@ -89,5 +76,8 @@ setup( 'Programming Language :: Python :: 3.4', 'Programming Language :: Python :: 3.5', ], - **kw + install_requires=[ + 'pycrypto>=2.1,!=2.4', + 'ecdsa>=0.11', + ], ) |