diff options
author | Jeff Forcier <jeff@bitprophet.org> | 2014-09-06 16:07:24 -0700 |
---|---|---|
committer | Jeff Forcier <jeff@bitprophet.org> | 2014-09-06 16:07:24 -0700 |
commit | 08239ff4b29c0b53c5443f21ae482e51340223f6 (patch) | |
tree | 73f0b7e4d25a80c965186d03abde9c006b1feec0 /setup.py | |
parent | 5335d9dc0a6266217d288e7aaf2091739980d841 (diff) | |
parent | 6a6ac4d78421667b810f5e3a017fb669853133f9 (diff) |
Merge branch 'master' into 234-int
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 61 |
1 files changed, 40 insertions, 21 deletions
@@ -40,9 +40,10 @@ import sys try: from setuptools import setup kw = { - 'install_requires': ['pycrypto >= 2.1, != 2.4', - 'ecdsa', - ], + 'install_requires': [ + 'pycrypto >= 2.1, != 2.4', + 'ecdsa', + ], } except ImportError: from distutils.core import setup @@ -53,21 +54,39 @@ if sys.platform == 'darwin': setup_helper.install_custom_make_tarball() -setup(name = "paramiko", - version = "1.12.0", - description = "SSH2 protocol library", - author = "Jeff Forcier", - author_email = "jeff@bitprophet.org", - url = "https://github.com/paramiko/paramiko/", - packages = [ 'paramiko' ], - license = 'LGPL', - platforms = 'Posix; MacOS X; Windows', - classifiers = [ 'Development Status :: 5 - Production/Stable', - 'Intended Audience :: Developers', - 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)', - 'Operating System :: OS Independent', - 'Topic :: Internet', - 'Topic :: Security :: Cryptography' ], - long_description = longdesc, - **kw - ) +# Version info -- read without importing +_locals = {} +with open('paramiko/_version.py') as fp: + exec(fp.read(), None, _locals) +version = _locals['__version__'] + + +setup( + name = "paramiko", + version = version, + description = "SSH2 protocol library", + long_description = longdesc, + author = "Jeff Forcier", + author_email = "jeff@bitprophet.org", + url = "https://github.com/paramiko/paramiko/", + packages = [ 'paramiko' ], + license = 'LGPL', + platforms = 'Posix; MacOS X; Windows', + classifiers = [ + 'Development Status :: 5 - Production/Stable', + 'Intended Audience :: Developers', + 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)', + 'Operating System :: OS Independent', + 'Topic :: Internet', + 'Topic :: Security :: Cryptography', + 'Programming Language :: Python', + 'Programming Language :: Python :: 2', + 'Programming Language :: Python :: 2.6', + 'Programming Language :: Python :: 2.7', + 'Programming Language :: Python :: 3', + 'Programming Language :: Python :: 3.2', + 'Programming Language :: Python :: 3.3', + 'Programming Language :: Python :: 3.4', + ], + **kw +) |