summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-07-01 17:05:17 -0700
committerFelix Fietkau <nbd@nbd.name>2016-12-01 11:28:47 +0100
commit374dc3f13623df58275d9da51637976c34be125d (patch)
treed7e9d021405075ee3ec47e08e45bffe56a83ec49 /CMakeLists.txt
parent01c919c49ccbc8ded444f7eedc1db04aa2fa2f9b (diff)
cmake: Find libubox/uloop.h
Add a CMake FIND_PATH and INCLUDE_DIRECTORIES searching for libubox/uloop.h. Some external toolchains which do not include standard locations would fail to find the header otherwise. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34a21d0..8c338f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,8 @@ project(odhcpd C)
set(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -std=c99")
+FIND_PATH(ubox_include_dir libubox/uloop.h)
+INCLUDE_DIRECTORIES(${ubox_include_dir})
add_definitions(-D_GNU_SOURCE -Wall -Werror -Wextra)