summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt1
-rw-r--r--config.c2
2 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index de0c74b..8fb8ae1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
SET(SOURCES ${SOURCES} system-linux.c)
SET(LIBS ${LIBS} nl)
ELSE()
+ ADD_DEFINITIONS(-DDUMMY_MODE=1)
SET(SOURCES ${SOURCES} system-dummy.c)
ENDIF()
diff --git a/config.c b/config.c
index 81cbd28..8705c16 100644
--- a/config.c
+++ b/config.c
@@ -215,7 +215,9 @@ config_init_interfaces(const char *name)
ctx = uci_alloc_context();
uci_ctx = ctx;
+#ifdef DUMMY_MODE
uci_set_confdir(ctx, "./config");
+#endif
if (uci_load(ctx, "network", &p)) {
fprintf(stderr, "Failed to load network config\n");