summaryrefslogtreecommitdiffhomepage
path: root/modules
diff options
context:
space:
mode:
Diffstat (limited to 'modules')
-rw-r--r--modules/luci-base/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 789e6a4bf6..d9832e3393 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -28,6 +28,7 @@ LUCI_DEPENDS:=\
+liblucihttp-ucode
PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE NOTICE
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
@@ -52,6 +53,11 @@ fi
exit 0
endef
+define Build/Prepare/luci-base
+ $(CP) ../../NOTICE $(PKG_BUILD_DIR)
+ $(CP) ../../LICENSE $(PKG_BUILD_DIR)
+endef
+
include ../../luci.mk
define Host/Configure