summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/remote-update/Makefile2
-rwxr-xr-xcontrib/package/remote-update/files/usr/sbin/remote-update10
2 files changed, 3 insertions, 9 deletions
diff --git a/contrib/package/remote-update/Makefile b/contrib/package/remote-update/Makefile
index dd73d2f55..f4affb496 100644
--- a/contrib/package/remote-update/Makefile
+++ b/contrib/package/remote-update/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=remote-update
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/contrib/package/remote-update/files/usr/sbin/remote-update b/contrib/package/remote-update/files/usr/sbin/remote-update
index e9a0a98c1..4fa7e38dc 100755
--- a/contrib/package/remote-update/files/usr/sbin/remote-update
+++ b/contrib/package/remote-update/files/usr/sbin/remote-update
@@ -19,16 +19,10 @@ find_image()
{
case "$1" in
atheros)
- if grep -q '"vmlinux.bin.l7"' /proc/mtd; then
- echo "openwrt-fonera-combined.img"
- else
- echo "openwrt-ubiquity-combined.img"
- fi
+ echo "openwrt-atheros-combined.img"
;;
ar71xx)
- if grep -q '"kernel"' /proc/mtd; then
- echo "openwrt-ar71xx-combined.img"
- fi
+ echo "openwrt-ar71xx-combined.img"
;;
brcm-2.4)
echo "openwrt-brcm-2.4-squashfs.trx"