summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-10-19 12:17:41 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-10-19 12:17:41 +0000
commitaf8424549d01651b188e2569cab5169d2e933bc0 (patch)
treea815fe3f4ea478f64234054f6a1a71a8c508c7ce /contrib/package
parent536430d0eeecf5c75651ff625b97c9fa4fc646b4 (diff)
contrib/package: remote-update: now expect "openwrt-atheros-combined.img" since we switch to upstream combined images
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/remote-update/Makefile2
-rwxr-xr-xcontrib/package/remote-update/files/usr/sbin/remote-update10
2 files changed, 3 insertions, 9 deletions
diff --git a/contrib/package/remote-update/Makefile b/contrib/package/remote-update/Makefile
index dd73d2f55..f4affb496 100644
--- a/contrib/package/remote-update/Makefile
+++ b/contrib/package/remote-update/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=remote-update
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/contrib/package/remote-update/files/usr/sbin/remote-update b/contrib/package/remote-update/files/usr/sbin/remote-update
index e9a0a98c1..4fa7e38dc 100755
--- a/contrib/package/remote-update/files/usr/sbin/remote-update
+++ b/contrib/package/remote-update/files/usr/sbin/remote-update
@@ -19,16 +19,10 @@ find_image()
{
case "$1" in
atheros)
- if grep -q '"vmlinux.bin.l7"' /proc/mtd; then
- echo "openwrt-fonera-combined.img"
- else
- echo "openwrt-ubiquity-combined.img"
- fi
+ echo "openwrt-atheros-combined.img"
;;
ar71xx)
- if grep -q '"kernel"' /proc/mtd; then
- echo "openwrt-ar71xx-combined.img"
- fi
+ echo "openwrt-ar71xx-combined.img"
;;
brcm-2.4)
echo "openwrt-brcm-2.4-squashfs.trx"