summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-radicale/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-radicale/Makefile')
-rw-r--r--applications/luci-app-radicale/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/applications/luci-app-radicale/Makefile b/applications/luci-app-radicale/Makefile
new file mode 100644
index 000000000..07998aee5
--- /dev/null
+++ b/applications/luci-app-radicale/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2008-2015 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=luci-app-radicale
+
+# Version == major.minor.patch
+# increase "minor" on new functionality and "patch" on patches/optimization
+PKG_VERSION:=1.0.0
+
+# Release == build
+# increase on changes of translation files
+PKG_RELEASE:=1
+
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
+
+# LuCI specific settings
+LUCI_TITLE:=LuCI Support for Radicale CardDAV/CalDAV
+LUCI_DEPENDS:=+luci-mod-admin-full
+LUCI_PKGARCH:=all
+
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+ .
+ !!! Package "radicale-py2" or "radicale-py3" needs to be !!!
+ !!! installed sepearatly. There is no buildin dependency set !!!
+ .
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+ $(PKG_MAINTAINER)
+endef
+
+include $(TOPDIR)/feeds/luci/luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature