summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-pbr
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-pbr')
-rw-r--r--applications/luci-app-pbr/Makefile2
-rw-r--r--applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js21
-rw-r--r--applications/luci-app-pbr/po/templates/pbr.pot135
-rwxr-xr-xapplications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr2
4 files changed, 88 insertions, 72 deletions
diff --git a/applications/luci-app-pbr/Makefile b/applications/luci-app-pbr/Makefile
index 45fb9acd25..3405337149 100644
--- a/applications/luci-app-pbr/Makefile
+++ b/applications/luci-app-pbr/Makefile
@@ -7,7 +7,7 @@ PKG_NAME:=luci-app-pbr
PKG_LICENSE:=AGPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
PKG_VERSION:=1.1.7
-PKG_RELEASE:=21
+PKG_RELEASE:=29
LUCI_TITLE:=Policy Based Routing Service Web UI
LUCI_URL:=https://github.com/stangri/luci-app-pbr/
diff --git a/applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js b/applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js
index fc2d9871cc..c8675423db 100644
--- a/applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js
+++ b/applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js
@@ -11,7 +11,7 @@ var pkg = {
return "pbr";
},
get ReadmeCompat() {
- return "1.1.7-21";
+ return "1.1.7-29";
},
get URL() {
return (
@@ -260,10 +260,21 @@ var status = baseclass.extend({
"The principal package (pbr) is outdated, please update it"
),
warningBadNftCallsInUserFile: _(
- "Incompatible nft calls detected in user include file, disabling fw4 nft file support."
+ "Incompatible nft calls detected in user include file, disabling fw4 nft file support"
),
warningDnsmasqInstanceNoConfdir: _(
- "Dnsmasq instance (%s) targeted in settings, but it doesn't have its own confdir."
+ "Dnsmasq instance (%s) targeted in settings, but it doesn't have its own confdir"
+ ),
+ warningDhcpLanForce: _(
+ _(
+ "Please set 'dhcp.lan.force=1' to speed up service start-up %s(more info)%s"
+ ).format(
+ "<a href='" +
+ pkg.URL +
+ "#Warning:Pleasesetdhcp.lan.force1" +
+ "' target='_blank'>",
+ "</a>"
+ )
),
};
var warningsTitle = E(
@@ -284,7 +295,7 @@ var status = baseclass.extend({
text += _("Unknown warning") + "<br />";
}
});
- var warningsText = E("div", {}, text);
+ var warningsText = E("div", { class: "cbi-value-description" }, text);
var warningsField = E(
"div",
{ class: "cbi-value-field" },
@@ -421,7 +432,7 @@ var status = baseclass.extend({
'<a href="' + pkg.URL + '" target="_blank">',
"</a>!<br />"
);
- var errorsText = E("div", {}, text);
+ var errorsText = E("div", { class: "cbi-value-description" }, text);
var errorsField = E("div", { class: "cbi-value-field" }, errorsText);
errorsDiv = E("div", { class: "cbi-value" }, [
errorsTitle,
diff --git a/applications/luci-app-pbr/po/templates/pbr.pot b/applications/luci-app-pbr/po/templates/pbr.pot
index 679336adbb..281d5b7921 100644
--- a/applications/luci-app-pbr/po/templates/pbr.pot
+++ b/applications/luci-app-pbr/po/templates/pbr.pot
@@ -2,11 +2,11 @@ msgid ""
msgstr "Content-Type: text/plain; charset=UTF-8"
#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:240
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:347
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:358
msgid "%s"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:305
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:316
msgid "%s binary cannot be found"
msgstr ""
@@ -65,7 +65,7 @@ msgstr ""
msgid "Chain"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:394
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:405
msgid "Command failed: '%s'"
msgstr ""
@@ -73,7 +73,7 @@ msgstr ""
msgid "Condensed output"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:302
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:313
msgid "Config (%s) validation failure"
msgstr ""
@@ -85,7 +85,7 @@ msgstr ""
msgid "Custom User File Includes"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:350
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:361
msgid "Custom user file '%s' not found or empty"
msgstr ""
@@ -105,15 +105,15 @@ msgstr ""
msgid "Default ICMP Interface"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:399
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:410
msgid "Default fw4 chain '%s' is missing"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:398
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:409
msgid "Default fw4 table '%s' is missing"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:531
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:542
msgid "Disable"
msgstr ""
@@ -123,7 +123,7 @@ msgstr ""
msgid "Disabled"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:525
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:536
msgid "Disabling %s service"
msgstr ""
@@ -134,7 +134,7 @@ msgstr ""
#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:266
msgid ""
"Dnsmasq instance (%s) targeted in settings, but it doesn't have its own "
-"confdir."
+"confdir"
msgstr ""
#: applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js:120
@@ -149,11 +149,11 @@ msgstr ""
msgid "Do not enforce policies when their gateway is down"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:578
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:589
msgid "Donate to the Project"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:512
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:523
msgid "Enable"
msgstr ""
@@ -165,15 +165,15 @@ msgstr ""
msgid "Enabled"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:506
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:517
msgid "Enabling %s service"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:352
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:363
msgid "Error running custom user file '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:420
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:431
msgid "Errors encountered, please check the %sREADME%s"
msgstr ""
@@ -183,31 +183,31 @@ msgid ""
"QoS. Change with caution together with"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:390
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:401
msgid "Failed to download '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:388
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:399
msgid "Failed to download '%s', HTTPS is not supported"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:383
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:394
msgid "Failed to install fw4 nft file '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:349
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:360
msgid "Failed to reload '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:379
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:390
msgid "Failed to resolve '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:348
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:359
msgid "Failed to set up '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:356
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:367
msgid "Failed to set up any gateway"
msgstr ""
@@ -235,25 +235,25 @@ msgstr ""
msgid "Inactive (Disabled)"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:396
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:407
msgid "Incompatible custom user file detected '%s'"
msgstr ""
#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:263
msgid ""
"Incompatible nft calls detected in user include file, disabling fw4 nft file "
-"support."
+"support"
msgstr ""
#: applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js:169
msgid "Insert"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:374
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:385
msgid "Insertion failed for IPv4 for policy '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:371
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:382
msgid "Insertion failed for both IPv4 and IPv6 for policy '%s'"
msgstr ""
@@ -265,7 +265,7 @@ msgstr ""
msgid "Interface"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:342
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:353
msgid "Interface '%s' has no assigned DNS"
msgstr ""
@@ -273,7 +273,7 @@ msgstr ""
msgid "Invalid OpenVPN config for %s interface"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:381
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:392
msgid "Invalid OpenVPN config for '%s' interface"
msgstr ""
@@ -286,7 +286,7 @@ msgstr ""
msgid "Local ports"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:365
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:376
msgid "Mismatched IP family between in policy '%s'"
msgstr ""
@@ -332,7 +332,7 @@ msgid "Path"
msgstr ""
#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:215
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:586
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:597
msgid "Please %sdonate%s to support development of this project."
msgstr ""
@@ -340,6 +340,11 @@ msgstr ""
msgid "Please check the %sREADME%s before changing this option."
msgstr ""
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:270
+msgid ""
+"Please set 'dhcp.lan.force=1' to speed up service start-up %s(more info)%s"
+msgstr ""
+
#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:248
msgid "Please unset 'chain' or set 'chain' to 'PREROUTING' for policy '%s'"
msgstr ""
@@ -360,23 +365,23 @@ msgstr ""
msgid "Policies"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:345
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:356
msgid "Policy '%s' has an unknown interface"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:340
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:351
msgid "Policy '%s' has no assigned DNS"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:339
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:350
msgid "Policy '%s' has no assigned interface"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:337
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:348
msgid "Policy '%s' has no source/destination parameters"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:385
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:396
msgid ""
"Policy '%s' refers to URL which can't be downloaded in 'secure_reload' mode"
msgstr ""
@@ -401,11 +406,11 @@ msgstr ""
msgid "Protocol"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:377
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:388
msgid "Received empty tid/mark or interface name when setting up routing"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:325
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:336
msgid "Refer to https://docs.openwrt.melmac.net/pbr/#procd_wan_interface"
msgstr ""
@@ -421,15 +426,15 @@ msgstr ""
msgid "Remote ports"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:400
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:411
msgid "Required binary '%s' is missing"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:357
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:368
msgid "Resolver '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:313
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:324
msgid "Resolver set (%s) is not supported on this system"
msgstr ""
@@ -437,21 +442,21 @@ msgstr ""
msgid "Resolver set (%s) is not supported on this system."
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:307
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:318
msgid ""
"Resolver set support (%s) requires ipset, but ipset binary cannot be found"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:310
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:321
msgid ""
"Resolver set support (%s) requires nftables, but nft binary cannot be found"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:474
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:485
msgid "Restart"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:468
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:479
msgid "Restarting %s service"
msgstr ""
@@ -477,11 +482,11 @@ msgstr ""
msgid "Select Add for -A/add and Insert for -I/Insert."
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:557
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:568
msgid "Service Control"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:405
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:416
msgid "Service Errors"
msgstr ""
@@ -498,7 +503,7 @@ msgstr ""
msgid "Service Status"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:272
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:283
msgid "Service Warnings"
msgstr ""
@@ -508,15 +513,15 @@ msgid ""
"%sREADME%s for details."
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:359
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:370
msgid "Skipping IPv6 policy '%s' as IPv6 support is disabled"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:455
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:466
msgid "Start"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:449
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:460
msgid "Starting %s service"
msgstr ""
@@ -530,7 +535,7 @@ msgstr ""
msgid "Status"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:493
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:504
msgid "Stop"
msgstr ""
@@ -542,7 +547,7 @@ msgstr ""
msgid "Stopped."
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:487
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:498
msgid "Stopping %s service"
msgstr ""
@@ -566,7 +571,7 @@ msgstr ""
msgid "Suppress/No output"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:351
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:362
msgid "Syntax error in custom user file '%s'"
msgstr ""
@@ -574,7 +579,7 @@ msgstr ""
msgid "The %s indicates default gateway. See the %sREADME%s for details."
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:322
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:333
msgid ""
"The %s interface not found, you need to set the 'pbr.config."
"procd_wan_interface' option"
@@ -584,11 +589,11 @@ msgstr ""
msgid "The %s is not supported on this system."
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:319
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:330
msgid "The %s service failed to discover WAN gateway"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:316
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:327
msgid "The %s service is currently disabled"
msgstr ""
@@ -600,15 +605,15 @@ msgstr ""
msgid "The WebUI application (luci-app-pbr) is outdated, please update it"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:392
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:403
msgid "The file:// schema requires curl, but it's not detected on this system"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:328
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:339
msgid "The ipset name '%s' is longer than allowed 31 characters"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:331
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:342
msgid "The nft set name '%s' is longer than allowed 255 characters"
msgstr ""
@@ -616,27 +621,27 @@ msgstr ""
msgid "The principal package (pbr) is outdated, please update it"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:334
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:345
msgid "Unexpected exit or service termination: '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:417
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:428
msgid "Unknown error!"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:362
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:373
msgid "Unknown packet mark for interface '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:368
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:379
msgid "Unknown protocol in policy '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:284
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:295
msgid "Unknown warning"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:354
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:365
msgid ""
"Use of 'curl' is detected in custom user file '%s', but 'curl' isn't "
"installed"
diff --git a/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr b/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr
index bcdf39a5b2..25bb277c72 100755
--- a/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr
+++ b/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr
@@ -11,7 +11,7 @@
# ubus -S call luci.pbr getGateways '{"name": "pbr" }'
# ubus -S call luci.pbr getInterfaces '{"name": "pbr" }'
-readonly luciCompat='8'
+readonly luciCompat='9'
readonly pbrFunctionsFile='/etc/init.d/pbr'
if [ -s "$pbrFunctionsFile" ]; then
# shellcheck source=../../../../../pbr/files/etc/init.d/pbr