summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-advanced-reboot
diff options
context:
space:
mode:
Diffstat (limited to 'applications/luci-app-advanced-reboot')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile1
-rw-r--r--applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js8
-rw-r--r--applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json14
3 files changed, 19 insertions, 4 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index 46ebedae9d..a4192271cd 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -7,6 +7,7 @@ PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
LUCI_TITLE:=Advanced Linksys Reboot Web UI
+LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot supported Linksys and ZyXEL routers to\
an alternative partition. Also provides Web UI to shut down (power off) your device. Supported dual-partition\
routers are listed at https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
diff --git a/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js b/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
index 794ac8565e..c9cc20bec0 100644
--- a/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
+++ b/applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
@@ -51,7 +51,7 @@ return view.extend({
'click': ui.hideModal
}, _('Cancel')), ' ',
E('button', {
- 'class': 'cbi-button cbi-button-positive important',
+ 'class': 'btn cbi-button cbi-button-positive important',
'click': L.bind(this.callPowerOff, this)
}, _('Proceed'))
])
@@ -134,7 +134,7 @@ return view.extend({
'click': ui.hideModal
}, _('Cancel')), ' ',
E('button', {
- 'class': 'cbi-button cbi-button-positive important',
+ 'class': 'btn cbi-button cbi-button-positive important',
'click': L.bind(this.handleTogglePartition, this)
}, _('Proceed'))
])
@@ -161,7 +161,7 @@ return view.extend({
_(partition.state),
partition.os.replace("Unknown", _("Unknown")).replace("Compressed", _("Compressed")),
E('button', {
- 'class': 'cbi-button cbi-button-apply important',
+ 'class': 'btn cbi-button cbi-button-apply important',
'click': ui.createHandlerFn(this, func)
}, text)
])
@@ -220,7 +220,7 @@ return view.extend({
body.appendChild(E('hr'));
body.appendChild(
poweroff_supported ? E('button', {
- 'class': 'cbi-button cbi-button-apply important',
+ 'class': 'btn cbi-button cbi-button-apply important',
'click': ui.createHandlerFn(this, 'handlePowerOff')
}, _('Perform power off...'))
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json
new file mode 100644
index 0000000000..b9067c4d4b
--- /dev/null
+++ b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json
@@ -0,0 +1,14 @@
+{
+ "vendorName": "Netgear",
+ "deviceName": "WAC510",
+ "boardNames": [ "netgear,wac510" ],
+ "partition1MTD": "mtd9",
+ "partition2MTD": "mtd10",
+ "labelOffset": null,
+ "bootEnv1": "primary",
+ "bootEnv1Partition1Value": 0,
+ "bootEnv1Partition2Value": 3800000,
+ "bootEnv2": "secondary",
+ "bootEnv2Partition1Value": 3800000,
+ "bootEnv2Partition2Value": 0
+}