summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--applications/luci-app-simple-adblock/Makefile5
-rw-r--r--applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua7
2 files changed, 7 insertions, 5 deletions
diff --git a/applications/luci-app-simple-adblock/Makefile b/applications/luci-app-simple-adblock/Makefile
index d7be6850b..31055f120 100644
--- a/applications/luci-app-simple-adblock/Makefile
+++ b/applications/luci-app-simple-adblock/Makefile
@@ -7,9 +7,10 @@ PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
LUCI_TITLE:=Simple Adblock Web UI
-LUCI_DEPENDS:=+simple-adblock
+LUCI_DESCRIPTION:=Provides Web UI for simple-adblock service.
+LUCI_DEPENDS:=+luci +simple-adblock
LUCI_PKGARCH:=all
-PKG_RELEASE:=2
+PKG_RELEASE:=5
include ../../luci.mk
diff --git a/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua b/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua
index ff4638e9b..e80cfb39e 100644
--- a/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua
+++ b/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua
@@ -11,10 +11,11 @@ end
function e.write(self, section, value)
if value == "1" then
- luci.sys.call("/etc/init.d/simple-adblock enable >/dev/null")
- luci.sys.call("/etc/init.d/simple-adblock start >/dev/null")
+ luci.sys.init.enable("simple-adblock")
+ luci.sys.init.start("simple-adblock")
else
- luci.sys.call("/etc/init.d/simple-adblock stop >/dev/null")
+ luci.sys.init.stop("simple-adblock")
+ luci.sys.init.disable("simple-adblock")
end
return Flag.write(self, section, value)
end