summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--applications/luci-app-sshtunnel/Makefile2
-rw-r--r--applications/luci-app-sshtunnel/htdocs/luci-static/resources/view/sshtunnel/ssh_servers.js8
2 files changed, 9 insertions, 1 deletions
diff --git a/applications/luci-app-sshtunnel/Makefile b/applications/luci-app-sshtunnel/Makefile
index 4298b6107f..f686ff103f 100644
--- a/applications/luci-app-sshtunnel/Makefile
+++ b/applications/luci-app-sshtunnel/Makefile
@@ -7,7 +7,7 @@ LUCI_TITLE:=LuCI support for SSH Tunnels (sshtunnel package)
PKG_MAINTAINER:=Sergey Ponomarev <stokito@gmail.com>
LUCI_DEPENDS:=+luci-base +sshtunnel
-PKG_VERSION:=1.0.0
+PKG_VERSION:=1.1.0
PKG_RELEASE:=1
include ../../luci.mk
diff --git a/applications/luci-app-sshtunnel/htdocs/luci-static/resources/view/sshtunnel/ssh_servers.js b/applications/luci-app-sshtunnel/htdocs/luci-static/resources/view/sshtunnel/ssh_servers.js
index 88c3692728..7a45ddc32b 100644
--- a/applications/luci-app-sshtunnel/htdocs/luci-static/resources/view/sshtunnel/ssh_servers.js
+++ b/applications/luci-app-sshtunnel/htdocs/luci-static/resources/view/sshtunnel/ssh_servers.js
@@ -127,6 +127,14 @@ return view.extend({
o.default = 'accept-new';
o.modalonly = true;
+ o = s.taboption('advanced', form.Value, 'ProxyCommand', _('Proxy tunnel command'),
+ _('The command to use to connect to the server.') + '<br />' +
+ _('For example, the following command would connect via an HTTP proxy:') + '<br />' +
+ '<code>ncat --proxy-type http --proxy-auth alice:secret --proxy 192.168.1.2:8080 %h %p</code>' +
+ _manSshConfig('ProxyCommand')
+ );
+ o.modalonly = true;
+
return m.render();
},
});