summaryrefslogtreecommitdiffhomepage
path: root/themes/luci-theme-material
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-04-12 13:38:15 +0200
committerFlorian Eckert <fe@dev.tdt.de>2023-01-09 13:07:42 +0100
commit21b40652d9b40210075ae1b00a548520a211c862 (patch)
tree27f2b462564e4279a4e09a4e7de19227eda9a587 /themes/luci-theme-material
parent8991355c337ec3532d543f73b52f7f261d03a157 (diff)
luci-theme-: add postrm script
Remove uci theme config section on uninstall. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'themes/luci-theme-material')
-rw-r--r--themes/luci-theme-material/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/themes/luci-theme-material/Makefile b/themes/luci-theme-material/Makefile
index 5bc16eb7db..0fdd55edd4 100644
--- a/themes/luci-theme-material/Makefile
+++ b/themes/luci-theme-material/Makefile
@@ -9,6 +9,14 @@ include $(TOPDIR)/rules.mk
LUCI_TITLE:=Material Theme
LUCI_DEPENDS:=
+define Package/luci-theme-material/postrm
+#!/bin/sh
+[ -n "$${IPKG_INSTROOT}" ] || {
+ uci -q delete luci.themes.Material
+ uci commit luci
+}
+endef
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature