summaryrefslogtreecommitdiffhomepage
path: root/themes/luci-theme-bootstrap/Makefile
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-04-12 13:38:15 +0200
committerFlorian Eckert <fe@dev.tdt.de>2023-01-09 13:07:42 +0100
commit21b40652d9b40210075ae1b00a548520a211c862 (patch)
tree27f2b462564e4279a4e09a4e7de19227eda9a587 /themes/luci-theme-bootstrap/Makefile
parent8991355c337ec3532d543f73b52f7f261d03a157 (diff)
luci-theme-: add postrm script
Remove uci theme config section on uninstall. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'themes/luci-theme-bootstrap/Makefile')
-rw-r--r--themes/luci-theme-bootstrap/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/themes/luci-theme-bootstrap/Makefile b/themes/luci-theme-bootstrap/Makefile
index 1bb205ee05..1e7f49a12e 100644
--- a/themes/luci-theme-bootstrap/Makefile
+++ b/themes/luci-theme-bootstrap/Makefile
@@ -11,6 +11,16 @@ LUCI_DEPENDS:=
PKG_LICENSE:=Apache-2.0
+define Package/luci-theme-bootstrap/postrm
+#!/bin/sh
+[ -n "$${IPKG_INSTROOT}" ] || {
+ uci -q delete luci.themes.Bootstrap
+ uci -q delete luci.themes.BootstrapDark
+ uci -q delete luci.themes.BootstrapLight
+ uci commit luci
+}
+endef
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature