summaryrefslogtreecommitdiffhomepage
path: root/protocols
diff options
context:
space:
mode:
authorRemy D. Farley <one-d-wide@protonmail.com>2024-06-19 08:58:30 +0000
committerPaul Donald <newtwen+github@gmail.com>2024-06-30 17:25:24 +0200
commit39bc55695f81ed4553f342cc8adf507e95badc6b (patch)
treef657c093b2799748e0bfda4ef074c19a5fe75fbf /protocols
parent9d049d755a9ef729474b6dfa81e89a6bd1e03a8f (diff)
luci-proto-yggdrasil: show peer latency
Signed-off-by: Remy D. Farley <one-d-wide@protonmail.com>
Diffstat (limited to 'protocols')
-rw-r--r--protocols/luci-proto-yggdrasil/Makefile2
-rw-r--r--protocols/luci-proto-yggdrasil/htdocs/luci-static/resources/protocol/yggdrasil.js5
2 files changed, 6 insertions, 1 deletions
diff --git a/protocols/luci-proto-yggdrasil/Makefile b/protocols/luci-proto-yggdrasil/Makefile
index bc95e4b0bd..c864ac4aa2 100644
--- a/protocols/luci-proto-yggdrasil/Makefile
+++ b/protocols/luci-proto-yggdrasil/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
LUCI_TITLE:=Support for Yggdrasil Network
LUCI_DEPENDS:=+yggdrasil
LUCI_PKGARCH:=all
-PKG_VERSION:=1.1.0
+PKG_VERSION:=1.1.1
PKG_MAINTAINER:=William Fleurant <meshnet@protonmail.com>
include ../../luci.mk
diff --git a/protocols/luci-proto-yggdrasil/htdocs/luci-static/resources/protocol/yggdrasil.js b/protocols/luci-proto-yggdrasil/htdocs/luci-static/resources/protocol/yggdrasil.js
index d02095beb4..f216f8b16f 100644
--- a/protocols/luci-proto-yggdrasil/htdocs/luci-static/resources/protocol/yggdrasil.js
+++ b/protocols/luci-proto-yggdrasil/htdocs/luci-static/resources/protocol/yggdrasil.js
@@ -98,6 +98,10 @@ function updateActivePeers(ifname) {
cell = row.insertCell(-1)
cell.className = "td"
+ cell.textContent = '%.2f ms'.format(peer.latency_ms / 10**6);
+
+ cell = row.insertCell(-1)
+ cell.className = "td"
cell.textContent = '%.2mB'.format(peer.bytes_recvd);
cell = row.insertCell(-1)
@@ -136,6 +140,7 @@ var cbiActivePeers = form.DummyValue.extend({
E('th', {'class': 'th'}, _('Dir')),
E('th', {'class': 'th'}, _('IP Address')),
E('th', {'class': 'th'}, _('Uptime')),
+ E('th', {'class': 'th'}, _('Latency')),
E('th', {'class': 'th'}, _('RX')),
E('th', {'class': 'th'}, _('TX')),
E('th', {'class': 'th'}, _('Priority')),