summaryrefslogtreecommitdiffhomepage
path: root/protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua')
-rw-r--r--protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua32
1 files changed, 32 insertions, 0 deletions
diff --git a/protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua b/protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua
new file mode 100644
index 0000000000..d3e094f20f
--- /dev/null
+++ b/protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua
@@ -0,0 +1,32 @@
+--[[
+LuCI - Network model - homenet protocol extension
+
+Copyright 2014 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
+
+]]--
+
+local proto = luci.model.network:register_protocol("hnet")
+
+function proto.get_i18n(self)
+ return luci.i18n.translate("Automatic Homenet (HNCP)")
+end
+
+function proto.is_installed(self)
+ return nixio.fs.access("/lib/netifd/proto/hnet.sh")
+end
+
+function proto.opkg_package(self)
+ return "hnetd"
+end