summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-mod-status/ucode/template/admin_status/index.ut
diff options
context:
space:
mode:
authorMustafa Can Elmacı <mustafacan@elmaci.net>2024-11-17 15:52:45 +0300
committerPaul Donald <newtwen+github@gmail.com>2024-11-22 22:39:46 +0100
commitae8bbb814f16c2dc2a82e88d408bee1812ceda9c (patch)
treeb48de027e4f3d6a366ef60025b980bc83ee5ae90 /modules/luci-mod-status/ucode/template/admin_status/index.ut
parentaa955d6465b4d0f00cc713904e2de7bfb0cbd062 (diff)
treewide: HTML Cleanup
* HTML Cleanup: Meta tags. * Converted charset to shorthand. * Removed meta tags with `Content-Script-Type` attribute. (Invalid in HTML5 spec.) * HTML Cleanup: CSS tags. * Removed `type` attribute with CSS files from link tags. (HTML5 spec recommends omitting it.) * Removed `type` attribute from style tags. (Deprecated in HTML5 spec.) https://html.spec.whatwg.org/#attr-link-type https://developer.mozilla.org/en-US/docs/Web/HTML/Element/style * HTML Cleanup: Convert from XHTML to HTML5 * Removed XML declaration. * Removed XML namespace. * Changed doctype to HTML5. * HTML Cleanup: CDATA tags. * CDATA sections should not be used within HTML they are considered as comments and not displayed. https://developer.mozilla.org/en-US/docs/Web/API/CDATASection * HTML Cleanup: Script tags. * Removed `language` attribute from script tags. (No longer valid in HTML5) * Removed `type` attribute with JavaScript MIME type from script tags. (HTML5 spec recommends omitting it.) https://html.spec.whatwg.org/multipage/scripting.html#attr-script-type https://mimesniff.spec.whatwg.org/#javascript-mime-type Signed-off-by: Mustafa Can Elmacı <mustafacan@elmaci.net>
Diffstat (limited to 'modules/luci-mod-status/ucode/template/admin_status/index.ut')
-rw-r--r--modules/luci-mod-status/ucode/template/admin_status/index.ut6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/luci-mod-status/ucode/template/admin_status/index.ut b/modules/luci-mod-status/ucode/template/admin_status/index.ut
index 4d018a3efd..dafb427bf4 100644
--- a/modules/luci-mod-status/ucode/template/admin_status/index.ut
+++ b/modules/luci-mod-status/ucode/template/admin_status/index.ut
@@ -12,7 +12,7 @@
<div class="spinning">{{ _('Loading view…') }}</div>
</div>
-<script type="text/javascript">//<![CDATA[
+<script>
function progressbar(query, value, max, byte)
{
var pg = document.querySelector(query),
@@ -46,7 +46,7 @@ function renderBadge(icon, title) {
]);
}
-//]]></script>
+</script>
<div class="includes" style="display:none">
{%
@@ -60,7 +60,7 @@ function renderBadge(icon, title) {
%}
</div>
-<script type="text/javascript">
+<script>
L.require('ui').then(function(ui) {
ui.instantiateView('status/index');
});