summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-mod-admin-mini/luasrc/model/cbi/mini/luci.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/luci-mod-admin-mini/luasrc/model/cbi/mini/luci.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/luci-mod-admin-mini/luasrc/model/cbi/mini/luci.lua')
-rw-r--r--modules/luci-mod-admin-mini/luasrc/model/cbi/mini/luci.lua48
1 files changed, 48 insertions, 0 deletions
diff --git a/modules/luci-mod-admin-mini/luasrc/model/cbi/mini/luci.lua b/modules/luci-mod-admin-mini/luasrc/model/cbi/mini/luci.lua
new file mode 100644
index 0000000000..78255c1d97
--- /dev/null
+++ b/modules/luci-mod-admin-mini/luasrc/model/cbi/mini/luci.lua
@@ -0,0 +1,48 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+require "luci.config"
+local fs = require "nixio.fs"
+
+m = Map("luci", translate("Web <abbr title=\"User Interface\">UI</abbr>"), translate("Here you can customize the settings and the functionality of <abbr title=\"Lua Configuration Interface\">LuCI</abbr>."))
+
+-- force reload of global luci config namespace to reflect the changes
+function m.commit_handler(self)
+ package.loaded["luci.config"] = nil
+ require "luci.config"
+end
+
+
+c = m:section(NamedSection, "main", "core", translate("General"))
+
+l = c:option(ListValue, "lang", translate("Language"))
+l:value("auto")
+
+local i18ndir = luci.i18n.i18ndir .. "base."
+for k, v in luci.util.kspairs(luci.config.languages) do
+ local file = i18ndir .. k:gsub("_", "-")
+ if k:sub(1, 1) ~= "." and fs.access(file .. ".lmo") then
+ l:value(k, v)
+ end
+end
+
+t = c:option(ListValue, "mediaurlbase", translate("Design"))
+for k, v in pairs(luci.config.themes) do
+ if k:sub(1, 1) ~= "." then
+ t:value(v, k)
+ end
+end
+
+return m