summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-mod-admin-full/luasrc/model/cbi/admin_system/buttons.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/luci-mod-admin-full/luasrc/model/cbi/admin_system/buttons.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/luci-mod-admin-full/luasrc/model/cbi/admin_system/buttons.lua')
-rw-r--r--modules/luci-mod-admin-full/luasrc/model/cbi/admin_system/buttons.lua38
1 files changed, 38 insertions, 0 deletions
diff --git a/modules/luci-mod-admin-full/luasrc/model/cbi/admin_system/buttons.lua b/modules/luci-mod-admin-full/luasrc/model/cbi/admin_system/buttons.lua
new file mode 100644
index 0000000000..d7581830d3
--- /dev/null
+++ b/modules/luci-mod-admin-full/luasrc/model/cbi/admin_system/buttons.lua
@@ -0,0 +1,38 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+m = Map("system", translate("Buttons"),
+ translate("This page allows the configuration of custom button actions"))
+
+s = m:section(TypedSection, "button", "")
+s.anonymous = true
+s.addremove = true
+
+s:option(Value, "button", translate("Name"))
+
+act = s:option(ListValue, "action",
+ translate("Action"),
+ translate("Specifies the button state to handle"))
+
+act:value("released")
+
+s:option(Value, "handler",
+ translate("Handler"),
+ translate("Path to executable which handles the button event"))
+
+min = s:option(Value, "min", translate("Minimum hold time"))
+min.rmempty = true
+
+max = s:option(Value, "max", translate("Maximum hold time"))
+max.rmempty = true