summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-lua-runtime/src
diff options
context:
space:
mode:
authorAnari Jalakas <anari.jalakas@gmail.com>2024-11-11 21:06:08 +0200
committerPaul Donald <newtwen+github@gmail.com>2024-11-17 23:23:42 +0100
commita403707b57df38c60de8e0f71d968164291542dc (patch)
tree6873cee09aa05e3a125f934a20686f3ad79ed092 /modules/luci-lua-runtime/src
parent44fbd008fb3fe03d9f05697ac650c0d907852962 (diff)
luci-lua-runtime: fix build error with LTO
Adding $(FPIC) parameter fixes building with CONFIG_USE_LTO enabled. Signed-off-by: Anari Jalakas <anari.jalakas@gmail.com>
Diffstat (limited to 'modules/luci-lua-runtime/src')
-rw-r--r--modules/luci-lua-runtime/src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/luci-lua-runtime/src/Makefile b/modules/luci-lua-runtime/src/Makefile
index dcce33dc8c..9dbaff4ee0 100644
--- a/modules/luci-lua-runtime/src/Makefile
+++ b/modules/luci-lua-runtime/src/Makefile
@@ -13,7 +13,7 @@ clean:
rm -f contrib/lemon parser.so plural_formula.c plural_formula.h *.o
parser.so: template_parser.o template_utils.o template_lmo.o template_lualib.o plural_formula.o
- $(CC) $(LDFLAGS) -shared -o $@ $^
+ $(CC) $(LDFLAGS) $(FPIC) -shared -o $@ $^
version.lua:
./mkversion.sh $@ $(LUCI_VERSION) "$(LUCI_GITBRANCH)"