summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-lua-runtime/src/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2022-09-13 23:50:12 +0200
committerJo-Philipp Wich <jo@mein.io>2022-10-25 01:03:37 +0200
commit673f38246ac3548caefec41183e3dd7477d9f6f6 (patch)
treeb3b7682b14d8a81286f8b7fe2aa5239e5dfbf4b7 /modules/luci-lua-runtime/src/Makefile
parentded8ccf93ec5163be35c41501869110e5dab30d1 (diff)
treewide: separate Lua runtime resources
Move classes required for Lua runtime support into a new `luci-lua-runtime` package. Also replace the `luci.http` and `luci.util` classes in `luci-lib-base` with stubbed versions interacting with the ucode based runtime environment. Finally merge `luci-base-ucode` into the remainders of `luci-base`. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'modules/luci-lua-runtime/src/Makefile')
-rw-r--r--modules/luci-lua-runtime/src/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/modules/luci-lua-runtime/src/Makefile b/modules/luci-lua-runtime/src/Makefile
new file mode 100644
index 0000000000..dcce33dc8c
--- /dev/null
+++ b/modules/luci-lua-runtime/src/Makefile
@@ -0,0 +1,26 @@
+%.o: %.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(FPIC) -DNDEBUG -c -o $@ $<
+
+contrib/lemon: contrib/lemon.c contrib/lempar.c
+ cc -o contrib/lemon $<
+
+plural_formula.c: plural_formula.y contrib/lemon
+ ./contrib/lemon -q $<
+
+template_lmo.c: plural_formula.c
+
+clean:
+ rm -f contrib/lemon parser.so plural_formula.c plural_formula.h *.o
+
+parser.so: template_parser.o template_utils.o template_lmo.o template_lualib.o plural_formula.o
+ $(CC) $(LDFLAGS) -shared -o $@ $^
+
+version.lua:
+ ./mkversion.sh $@ $(LUCI_VERSION) "$(LUCI_GITBRANCH)"
+
+compile: parser.so version.lua
+
+install: compile
+ mkdir -p $(DESTDIR)/usr/lib/lua/luci/template
+ cp parser.so $(DESTDIR)/usr/lib/lua/luci/template/parser.so
+ cp version.lua $(DESTDIR)/usr/lib/lua/luci/version.lua