summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-lua-runtime/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2022-09-13 23:50:12 +0200
committerJo-Philipp Wich <jo@mein.io>2022-10-25 01:03:37 +0200
commit673f38246ac3548caefec41183e3dd7477d9f6f6 (patch)
treeb3b7682b14d8a81286f8b7fe2aa5239e5dfbf4b7 /modules/luci-lua-runtime/Makefile
parentded8ccf93ec5163be35c41501869110e5dab30d1 (diff)
treewide: separate Lua runtime resources
Move classes required for Lua runtime support into a new `luci-lua-runtime` package. Also replace the `luci.http` and `luci.util` classes in `luci-lib-base` with stubbed versions interacting with the ucode based runtime environment. Finally merge `luci-base-ucode` into the remainders of `luci-base`. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'modules/luci-lua-runtime/Makefile')
-rw-r--r--modules/luci-lua-runtime/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/modules/luci-lua-runtime/Makefile b/modules/luci-lua-runtime/Makefile
new file mode 100644
index 0000000000..2c6f38f08f
--- /dev/null
+++ b/modules/luci-lua-runtime/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2022 Jo-Philipp Wich <jo@mein.io>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=luci-lua-runtime
+
+LUCI_TYPE:=mod
+LUCI_BASENAME:=lua-runtime
+
+LUCI_TITLE:=LuCI Lua runtime libraries
+LUCI_DEPENDS:= \
+ +luci-base \
+ +lua \
+ +luci-lib-nixio \
+ +luci-lib-ip \
+ +luci-lib-jsonc \
+ +libubus-lua \
+ +liblucihttp-lua \
+ +ucode-mod-lua
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature