summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2024-12-02 08:35:39 +0100
committerGitHub <noreply@github.com>2024-12-02 08:35:39 +0100
commitb1968d9cdd6425821553138e0487df8840785afa (patch)
tree0109b11ab94eacca360b3e34ac96d11594a38b32 /modules/luci-base
parentb4d61a367a7d0727dbca3e1f3d482bbbc44a3646 (diff)
parent611ff53c736b968328515e1cc6e0baeb18b66b2c (diff)
Merge pull request #7115 from TDT-AG/pr/20240510-luci-base
luci-base: add PKG_LICENSE_FILES references to this packages
Diffstat (limited to 'modules/luci-base')
-rw-r--r--modules/luci-base/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 789e6a4bf6..d9832e3393 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -28,6 +28,7 @@ LUCI_DEPENDS:=\
+liblucihttp-ucode
PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE NOTICE
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
@@ -52,6 +53,11 @@ fi
exit 0
endef
+define Build/Prepare/luci-base
+ $(CP) ../../NOTICE $(PKG_BUILD_DIR)
+ $(CP) ../../LICENSE $(PKG_BUILD_DIR)
+endef
+
include ../../luci.mk
define Host/Configure