summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base
diff options
context:
space:
mode:
authorDaniel Dickinson <openwrt@daniel.thecshore.com>2015-12-01 21:36:30 -0500
committerDaniel Dickinson <openwrt@daniel.thecshore.com>2015-12-12 22:45:29 -0500
commit403b939acd55be528fa78bfc11521c78b1afdad8 (patch)
treee7ea2173f35cafdec8b4eb827b162e716ba89c3e /modules/luci-base
parent63155e99325d2f7b57eee99496648e7a3cf6c14b (diff)
modules/luci-base: Move LuCI FileUpload directory to /etc/luci-uploads and save across sysupgrade
/lib/uci/upload is a rather odd place for configuration files Also the files were not saved across sysupgrade, which is somewhat counter-productive for configuration files. Signed-off By: Daniel Dickinson <openwrt@daniel.thecshore.com>
Diffstat (limited to 'modules/luci-base')
-rw-r--r--modules/luci-base/Makefile4
-rw-r--r--modules/luci-base/luasrc/cbi.lua2
-rw-r--r--modules/luci-base/root/etc/luci-uploads/.placeholder (renamed from modules/luci-base/root/lib/uci/upload/.placeholder)0
3 files changed, 5 insertions, 1 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 26cbe0820..a9c5e71cb 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -22,6 +22,10 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/LuaSrcDiet-0.12.1
include $(INCLUDE_DIR)/host-build.mk
+define Package/luci-base/conffiles
+/etc/luci-uploads
+endef
+
include ../../luci.mk
define Host/Configure
diff --git a/modules/luci-base/luasrc/cbi.lua b/modules/luci-base/luasrc/cbi.lua
index b5b2c8d8f..8fd0a337e 100644
--- a/modules/luci-base/luasrc/cbi.lua
+++ b/modules/luci-base/luasrc/cbi.lua
@@ -38,7 +38,7 @@ function load(cbimap, ...)
require("luci.config")
require("luci.util")
- local upldir = "/lib/uci/upload/"
+ local upldir = "/etc/luci-uploads/"
local cbidir = luci.util.libpath() .. "/model/cbi/"
local func, err
diff --git a/modules/luci-base/root/lib/uci/upload/.placeholder b/modules/luci-base/root/etc/luci-uploads/.placeholder
index e69de29bb..e69de29bb 100644
--- a/modules/luci-base/root/lib/uci/upload/.placeholder
+++ b/modules/luci-base/root/etc/luci-uploads/.placeholder