summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base/src/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2022-10-27 12:36:33 +0200
committerJo-Philipp Wich <jo@mein.io>2022-10-27 12:36:33 +0200
commit2a5efb31b7b8a1fcd253b3897bed97abb0a67f4a (patch)
tree6ab98b8e3dd1eaefd5d820b5c193ce200cddffb1 /modules/luci-base/src/Makefile
parent1eea6c0ce8d5357204fb6248c0444e5495e1c191 (diff)
luci-base: always link core.so with libcrypt to satisfy glibc builds
Fixes the following runtime error on glibc based builds: Runtime error: Unable to dlopen file ...: undefined symbol: crypt In module(), file /usr/share/ucode/luci/dispatcher.uc, line 1, byte 1: called from anonymous function (/www/cgi-bin/luci:7:21) Ref: https://forum.openwrt.org/t/x/137250/18 Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'modules/luci-base/src/Makefile')
-rw-r--r--modules/luci-base/src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/luci-base/src/Makefile b/modules/luci-base/src/Makefile
index 896aeb0a38..ad309e5c6b 100644
--- a/modules/luci-base/src/Makefile
+++ b/modules/luci-base/src/Makefile
@@ -10,7 +10,7 @@ lib/plural_formula.c: lib/plural_formula.y contrib/lemon
lib/lmo.c: lib/plural_formula.c
core.so: lib/luci.o lib/lmo.o lib/plural_formula.o
- $(CC) $(LDFLAGS) -shared -o $@ $^
+ $(CC) $(LDFLAGS) -shared -lcrypt -o $@ $^
version.uc:
echo "export const revision = '$(LUCI_VERSION)', branch = '$(LUCI_GITBRANCH)';" > $@