summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2022-09-13 23:50:12 +0200
committerJo-Philipp Wich <jo@mein.io>2022-10-25 01:03:37 +0200
commit673f38246ac3548caefec41183e3dd7477d9f6f6 (patch)
treeb3b7682b14d8a81286f8b7fe2aa5239e5dfbf4b7 /modules/luci-base/Makefile
parentded8ccf93ec5163be35c41501869110e5dab30d1 (diff)
treewide: separate Lua runtime resources
Move classes required for Lua runtime support into a new `luci-lua-runtime` package. Also replace the `luci.http` and `luci.util` classes in `luci-lib-base` with stubbed versions interacting with the ucode based runtime environment. Finally merge `luci-base-ucode` into the remainders of `luci-base`. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'modules/luci-base/Makefile')
-rw-r--r--modules/luci-base/Makefile32
1 files changed, 29 insertions, 3 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 6cb2b64092..f85f753320 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2015 The LuCI Team <luci@lists.subsignal.org>
+# Copyright (C) 2022 Jo-Philipp Wich <jo@mein.io>
#
# This is free software, licensed under the Apache License, Version 2.0 .
#
@@ -11,8 +11,20 @@ PKG_NAME:=luci-base
LUCI_TYPE:=mod
LUCI_BASENAME:=base
-LUCI_TITLE:=LuCI core libraries
-LUCI_DEPENDS:=+lua +luci-lib-nixio +luci-lib-ip +rpcd +libubus-lua +luci-lib-jsonc +liblucihttp-lua +luci-lib-base +rpcd-mod-file +rpcd-mod-luci +cgi-io
+LUCI_TITLE:=LuCI core runtime
+LUCI_DEPENDS:=\
+ +rpcd \
+ +rpcd-mod-file \
+ +rpcd-mod-luci \
+ +rpcd-mod-ucode \
+ +cgi-io \
+ +ucode \
+ +ucode-mod-fs \
+ +ucode-mod-uci \
+ +ucode-mod-ubus \
+ +ucode-mod-math \
+ +ucode-mod-html \
+ +liblucihttp-ucode
PKG_LICENSE:=MIT
@@ -26,6 +38,20 @@ define Package/luci-base/conffiles
/etc/config/ucitrack
endef
+define Package/luci-base/postinst
+#!/bin/sh
+
+if [ -z "$${PKG_INSTROOT}" ] && [ -f /etc/config/uhttpd ]; then
+ if ! uci -q get uhttpd.main.ucode_prefix | grep -sq /cgi-bin/luci; then
+ uci add_list uhttpd.main.ucode_prefix='/cgi-bin/luci=/usr/share/ucode/luci/uhttpd.uc'
+ uci commit uhttpd
+ service uhttpd reload
+ fi
+fi
+
+exit 0
+endef
+
include ../../luci.mk
define Host/Configure