summaryrefslogtreecommitdiffhomepage
path: root/modules/base/luasrc/config.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/base/luasrc/config.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/base/luasrc/config.lua')
-rw-r--r--modules/base/luasrc/config.lua42
1 files changed, 0 insertions, 42 deletions
diff --git a/modules/base/luasrc/config.lua b/modules/base/luasrc/config.lua
deleted file mode 100644
index 53db82b322..0000000000
--- a/modules/base/luasrc/config.lua
+++ /dev/null
@@ -1,42 +0,0 @@
---[[
-LuCI - Configuration
-
-Description:
-Some LuCI configuration values read from uci file "luci"
-
-
-FileId:
-$Id$
-
-License:
-Copyright 2008 Steven Barth <steven@midlink.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-Unless required by applicable law or agreed to in writing, software
-distributed under the License is distributed on an "AS IS" BASIS,
-WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-See the License for the specific language governing permissions and
-limitations under the License.
-
-]]--
-
-local util = require "luci.util"
-module("luci.config",
- function(m)
- if pcall(require, "luci.model.uci") then
- local config = util.threadlocal()
- setmetatable(m, {
- __index = function(tbl, key)
- if not config[key] then
- config[key] = luci.model.uci.cursor():get_all("luci", key)
- end
- return config[key]
- end
- })
- end
- end)