summaryrefslogtreecommitdiffhomepage
path: root/modules/admin-full/luasrc/view/admin_uci/changelog.htm
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /modules/admin-full/luasrc/view/admin_uci/changelog.htm
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'modules/admin-full/luasrc/view/admin_uci/changelog.htm')
-rw-r--r--modules/admin-full/luasrc/view/admin_uci/changelog.htm88
1 files changed, 0 insertions, 88 deletions
diff --git a/modules/admin-full/luasrc/view/admin_uci/changelog.htm b/modules/admin-full/luasrc/view/admin_uci/changelog.htm
deleted file mode 100644
index e195befb3e..0000000000
--- a/modules/admin-full/luasrc/view/admin_uci/changelog.htm
+++ /dev/null
@@ -1,88 +0,0 @@
-<%#
-LuCI - Lua Configuration Interface
-Copyright 2010 Jo-Philipp Wich <xm@subsignal.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
--%>
-
-<% export("uci_changelog", function(changes) -%>
-<fieldset class="cbi-section">
- <strong><%:Legend:%></strong>
- <div class="uci-change-legend">
- <div class="uci-change-legend-label"><ins>&#160;</ins> <%:Section added%></div>
- <div class="uci-change-legend-label"><del>&#160;</del> <%:Section removed%></div>
- <div class="uci-change-legend-label"><var><ins>&#160;</ins></var> <%:Option changed%></div>
- <div class="uci-change-legend-label"><var><del>&#160;</del></var> <%:Option removed%></div>
- <br style="clear:both" />
- </div>
- <br />
-
- <div class="uci-change-list"><%
- local util = luci.util
- local ret = { }
-
- for r, tbl in pairs(changes) do
- for s, os in pairs(tbl) do
- -- section add
- if os['.type'] and os['.type'] ~= "" then
- ret[#ret+1] = "<ins>%s.%s=<strong>%s</strong>" %{ r, s, os['.type'] }
- for o, v in util.kspairs(os) do
- if o:sub(1,1) ~= "." then
- if type(v) == "table" then
- local i
- for i = 1, #v do
- ret[#ret+1] = "<br />%s.%s.%s+=<strong>%s</strong>"
- %{ r, s, o, util.pcdata(v[i]) }
- end
- else
- ret[#ret+1] = "<br />%s.%s.%s=<strong>%s</strong>"
- %{ r, s, o, util.pcdata(v) }
- end
- end
- end
- ret[#ret+1] = "</ins><br />"
-
- -- section delete
- elseif os['.type'] and os['.type'] == "" then
- ret[#ret+1] = "<del>%s.<strong>%s</strong></del><br />" %{ r, s }
-
- -- modifications
- else
- ret[#ret+1] = "<var>%s.%s<br />" %{ r, s }
- for o, v in util.kspairs(os) do
- if o:sub(1,1) ~= "." then
- if v and #v > 0 then
- ret[#ret+1] = "<ins>"
- if type(v) == "table" then
- local i
- for i = 1, #v do
- ret[#ret+1] = "%s.%s.%s+=<strong>%s</strong><br />"
- %{ r, s, o, util.pcdata(v[i]) }
- end
-
- else
- ret[#ret+1] = "%s.%s.%s=<strong>%s</strong><br />"
- %{ r, s, o, util.pcdata(v) }
- end
- ret[#ret+1] = "</ins>"
- else
- ret[#ret+1] = "<del>%s.%s.<strong>%s</strong><br /></del>" %{ r, s, o }
- end
- end
- end
- ret[#ret+1] = "</var><br />"
- end
- end
- end
-
- write(table.concat(ret))
- %></div>
-</fieldset>
-<%- end) %>