summaryrefslogtreecommitdiffhomepage
path: root/luci.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-03-11 12:23:37 +0100
committerJo-Philipp Wich <jow@openwrt.org>2016-03-11 12:23:37 +0100
commitecb9ee8e5d986a68d681e207e54b63a7d9effb24 (patch)
treea624ec0aa1e192841c8752b534efd92b9586a3c9 /luci.mk
parentac9b31ca462b5662e98a0ac6b57fb49c4c4e32de (diff)
parent7553654bb10af9206cff9837a485b828d1998213 (diff)
Merge pull request #669 from hnyman/git-branch
LuCI: Display the proper LuCI git branch in GUI
Diffstat (limited to 'luci.mk')
-rw-r--r--luci.mk15
1 files changed, 14 insertions, 1 deletions
diff --git a/luci.mk b/luci.mk
index 1e56edde50..5b32dab2ff 100644
--- a/luci.mk
+++ b/luci.mk
@@ -66,6 +66,19 @@ PKG_VERSION?=$(if $(DUMP),x,$(strip $(shell \
echo "$$revision" \
)))
+PKG_GITBRANCH?=$(if $(DUMP),x,$(strip $(shell \
+ variant="LuCI"; \
+ if git log -1 >/dev/null 2>/dev/null; then \
+ branch="$$(git symbolic-ref --short -q HEAD 2>/dev/null)"; \
+ if [ "$$branch" != "master" ]; then \
+ variant="LuCI $$branch branch"; \
+ else \
+ variant="LuCI Master"; \
+ fi; \
+ fi; \
+ echo "$$variant" \
+)))
+
PKG_RELEASE?=1
PKG_INSTALL:=$(if $(realpath src/Makefile),1)
PKG_BUILD_DEPENDS += lua/host luci-base/host $(LUCI_BUILD_DEPENDS)
@@ -121,7 +134,7 @@ endef
ifneq ($(wildcard ${CURDIR}/src/Makefile),)
MAKE_PATH := src/
- MAKE_VARS += FPIC="$(FPIC)" LUCI_VERSION="$(PKG_VERSION)"
+ MAKE_VARS += FPIC="$(FPIC)" LUCI_VERSION="$(PKG_VERSION)" LUCI_GITBRANCH="$(PKG_GITBRANCH)"
define Build/Compile
$(call Build/Compile/Default,clean compile)