summaryrefslogtreecommitdiffhomepage
path: root/luci.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-09 22:43:57 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-09 22:44:15 +0200
commit4d97a9f6986fb37ce7e69a1ca3f4743334495654 (patch)
treeed787f20036e88d54c8378981b2f40622ff6f0af /luci.mk
parente06c60a0d669bed72e495d51f5e30513b05f5605 (diff)
luci-base: use default install paths for host utils
This reverts commit d4c33720208346ee7983213fe764df3102b8a771. PATH inconsistencies and Host/Install arguments have been fixed in both LEDE and OpenWrt, so we can revert the revert. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'luci.mk')
-rw-r--r--luci.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/luci.mk b/luci.mk
index eb034d208..84d151230 100644
--- a/luci.mk
+++ b/luci.mk
@@ -150,8 +150,7 @@ LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci
define SrcDiet
$(FIND) $(1) -type f -name '*.lua' | while read src; do \
- if $(STAGING_DIR)/host/bin/lua $(STAGING_DIR)/host/bin/LuaSrcDiet \
- --noopt-binequiv -o "$$$$src.o" "$$$$src"; \
+ if LuaSrcDiet --noopt-binequiv -o "$$$$src.o" "$$$$src"; \
then mv "$$$$src.o" "$$$$src"; fi; \
done
endef