summaryrefslogtreecommitdiffhomepage
path: root/libs
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-09 13:42:09 -1000
committerPaul Spooren <mail@aparcar.org>2020-08-20 15:54:54 -1000
commitc4a4e43e2e97065dcda53c9ac7ee49c05171dbd8 (patch)
tree5f2e877793a63c9e639410ce868d2f755f5db695 /libs
parent03253c23090a9928c15ab8d80c18b734e3e814ed (diff)
treewide: replace `which` with `command -v`
Fix shellcheck SC2230 > which is non-standard. Use builtin 'command -v' instead. Once applied to everything concerning OpenWrt we can disable the busybox feature `which` and save 3.8kB. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'libs')
-rw-r--r--libs/luci-lib-nixio/src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/libs/luci-lib-nixio/src/Makefile b/libs/luci-lib-nixio/src/Makefile
index a7e9a77d9..893656c25 100644
--- a/libs/luci-lib-nixio/src/Makefile
+++ b/libs/luci-lib-nixio/src/Makefile
@@ -51,7 +51,7 @@ ifeq ($(OS),SunOS)
endif
ifneq (,$(findstring MINGW,$(OS))$(findstring mingw,$(OS))$(findstring Windows,$(OS)))
- NIXIO_CROSS_CC:=$(shell which i586-mingw32msvc-cc)
+ NIXIO_CROSS_CC:=$(shell command -v i586-mingw32msvc-cc)
ifneq (,$(NIXIO_CROSS_CC))
CC:=$(NIXIO_CROSS_CC)
endif