summaryrefslogtreecommitdiffhomepage
path: root/libs/sgi-uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-06-11 13:29:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-06-11 13:29:05 +0000
commit7043c30e0e55bbbfacdddf97619b6bae96d20ddb (patch)
treeece3254350b3ba01ba3135caed2364cc7ca7804c /libs/sgi-uhttpd
parentbbb44cf245c11bc0c1d59e836007c9e8c3bfa209 (diff)
build: introduce luci-base
Merges libs/core, libs/ipkg, libs/web, libs/sys, libs/sgi-cgi, libs/sgi-uhttpd, modules/admin-core, themes/base and protcols/core into modules/base and renames luci-lib-core to luci-base.
Diffstat (limited to 'libs/sgi-uhttpd')
-rw-r--r--libs/sgi-uhttpd/Makefile2
-rw-r--r--libs/sgi-uhttpd/luasrc/sgi/uhttpd.lua105
2 files changed, 0 insertions, 107 deletions
diff --git a/libs/sgi-uhttpd/Makefile b/libs/sgi-uhttpd/Makefile
deleted file mode 100644
index 81a96f6a8..000000000
--- a/libs/sgi-uhttpd/Makefile
+++ /dev/null
@@ -1,2 +0,0 @@
-include ../../build/config.mk
-include ../../build/module.mk \ No newline at end of file
diff --git a/libs/sgi-uhttpd/luasrc/sgi/uhttpd.lua b/libs/sgi-uhttpd/luasrc/sgi/uhttpd.lua
deleted file mode 100644
index db8780f7e..000000000
--- a/libs/sgi-uhttpd/luasrc/sgi/uhttpd.lua
+++ /dev/null
@@ -1,105 +0,0 @@
---[[
-LuCI - Server Gateway Interface for the uHTTPd server
-
-Copyright 2010 Jo-Philipp Wich <xm@subsignal.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-Unless required by applicable law or agreed to in writing, software
-distributed under the License is distributed on an "AS IS" BASIS,
-WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-See the License for the specific language governing permissions and
-limitations under the License.
-
-]]--
-
-require "nixio.util"
-require "luci.http"
-require "luci.sys"
-require "luci.dispatcher"
-require "luci.ltn12"
-
-function handle_request(env)
- exectime = os.clock()
- local renv = {
- CONTENT_LENGTH = env.CONTENT_LENGTH,
- CONTENT_TYPE = env.CONTENT_TYPE,
- REQUEST_METHOD = env.REQUEST_METHOD,
- REQUEST_URI = env.REQUEST_URI,
- PATH_INFO = env.PATH_INFO,
- SCRIPT_NAME = env.SCRIPT_NAME:gsub("/+$", ""),
- SCRIPT_FILENAME = env.SCRIPT_NAME,
- SERVER_PROTOCOL = env.SERVER_PROTOCOL,
- QUERY_STRING = env.QUERY_STRING
- }
-
- local k, v
- for k, v in pairs(env.headers) do
- k = k:upper():gsub("%-", "_")
- renv["HTTP_" .. k] = v
- end
-
- local len = tonumber(env.CONTENT_LENGTH) or 0
- local function recv()
- if len > 0 then
- local rlen, rbuf = uhttpd.recv(4096)
- if rlen >= 0 then
- len = len - rlen
- return rbuf
- end
- end
- return nil
- end
-
- local send = uhttpd.send
-
- local req = luci.http.Request(
- renv, recv, luci.ltn12.sink.file(io.stderr)
- )
-
-
- local x = coroutine.create(luci.dispatcher.httpdispatch)
- local hcache = { }
- local active = true
-
- while coroutine.status(x) ~= "dead" do
- local res, id, data1, data2 = coroutine.resume(x, req)
-
- if not res then
- send("Status: 500 Internal Server Error\r\n")
- send("Content-Type: text/plain\r\n\r\n")
- send(tostring(id))
- break
- end
-
- if active then
- if id == 1 then
- send("Status: ")
- send(tostring(data1))
- send(" ")
- send(tostring(data2))
- send("\r\n")
- elseif id == 2 then
- hcache[data1] = data2
- elseif id == 3 then
- for k, v in pairs(hcache) do
- send(tostring(k))
- send(": ")
- send(tostring(v))
- send("\r\n")
- end
- send("\r\n")
- elseif id == 4 then
- send(tostring(data1 or ""))
- elseif id == 5 then
- active = false
- elseif id == 6 then
- data1:copyz(nixio.stdout, data2)
- end
- end
- end
-end