summaryrefslogtreecommitdiffhomepage
path: root/libs/sgi-cgi
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-15 17:45:10 +0000
committerSteven Barth <steven@midlink.org>2008-06-15 17:45:10 +0000
commiteae0e447989a1a37ce6cb8df9f1f353738aab4f6 (patch)
tree4d8568109967259150413e873af2592a6f975373 /libs/sgi-cgi
parent3455ee6d8d9eb3c0ee8459adb586a800dadaf737 (diff)
* Added support for CGI SGI
Diffstat (limited to 'libs/sgi-cgi')
-rw-r--r--libs/sgi-cgi/Makefile2
-rw-r--r--libs/sgi-cgi/htdocs/cgi-bin/luci4
-rw-r--r--libs/sgi-cgi/luasrc/sgi/cgi.lua57
3 files changed, 63 insertions, 0 deletions
diff --git a/libs/sgi-cgi/Makefile b/libs/sgi-cgi/Makefile
new file mode 100644
index 000000000..81a96f6a8
--- /dev/null
+++ b/libs/sgi-cgi/Makefile
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk \ No newline at end of file
diff --git a/libs/sgi-cgi/htdocs/cgi-bin/luci b/libs/sgi-cgi/htdocs/cgi-bin/luci
new file mode 100644
index 000000000..0435e59ba
--- /dev/null
+++ b/libs/sgi-cgi/htdocs/cgi-bin/luci
@@ -0,0 +1,4 @@
+#!/usr/bin/lua
+require("luci.sgi.cgi")
+luci.dispatcher.indexcache = "/tmp/.luciindex"
+luci.sgi.cgi.run() \ No newline at end of file
diff --git a/libs/sgi-cgi/luasrc/sgi/cgi.lua b/libs/sgi-cgi/luasrc/sgi/cgi.lua
new file mode 100644
index 000000000..7abb1ef78
--- /dev/null
+++ b/libs/sgi-cgi/luasrc/sgi/cgi.lua
@@ -0,0 +1,57 @@
+--[[
+LuCI - SGI-Module for CGI
+
+Description:
+Server Gateway Interface for CGI
+
+FileId:
+$Id$
+
+License:
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
+
+]]--
+module("luci.sgi.cgi", package.seeall)
+require("luci.http")
+require("luci.sys")
+require("luci.dispatcher")
+
+function run()
+ local r = luci.http.Request(luci.sys.getenv(), io.stdin, io.stderr)
+
+ local x = coroutine.create(luci.dispatcher.httpdispatch)
+
+ while coroutine.status(x) ~= "dead" do
+ local res, id, data1, data2 = coroutine.resume(x, r)
+
+ if not res then
+ print("Status: 500 Internal Server Error")
+ print("Content-Type: text/plain\n")
+ print(id)
+ break;
+ end
+
+ if id == 1 then
+ io.write("Status: " .. tostring(data1) .. " " .. data2 .. "\n")
+ elseif id == 2 then
+ io.write(data1 .. ": " .. data2 .. "\n")
+ elseif id == 3 then
+ io.write("\n")
+ elseif id == 4 then
+ io.write(data1)
+ end
+
+ end
+end