summaryrefslogtreecommitdiffhomepage
path: root/libs/nixio/docsrc/nixio.bin.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/nixio/docsrc/nixio.bin.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/nixio/docsrc/nixio.bin.lua')
-rw-r--r--libs/nixio/docsrc/nixio.bin.lua33
1 files changed, 0 insertions, 33 deletions
diff --git a/libs/nixio/docsrc/nixio.bin.lua b/libs/nixio/docsrc/nixio.bin.lua
deleted file mode 100644
index 13e125d3cc..0000000000
--- a/libs/nixio/docsrc/nixio.bin.lua
+++ /dev/null
@@ -1,33 +0,0 @@
---- Binary operations and conversion.
-module "nixio.bin"
-
---- Return a hexadecimal ASCII represantation of the content of a buffer.
--- @class function
--- @name hexlify
--- @param buffer Buffer
--- @return representation using characters [0-9a-f]
-
---- Return a binary buffer from a hexadecimal ASCII representation.
--- @class function
--- @name unhexlify
--- @param hexvalue representation using characters [0-9a-f]
--- @return binary data
-
---- Calculate the CRC32 value of a buffer.
--- @class function
--- @name crc32
--- @param buffer Buffer
--- @param initial Initial CRC32 value (optional)
--- @return crc32 value
-
---- Base64 encode a given buffer.
--- @class function
--- @name b64encode
--- @param buffer Buffer
--- @return base64 encoded buffer
-
---- Base64 decode a given buffer.
--- @class function
--- @name b64decode
--- @param buffer Base 64 Encoded data
--- @return binary data \ No newline at end of file