summaryrefslogtreecommitdiffhomepage
path: root/libs/nixio/axTLS/www/lua/test_sql2.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/nixio/axTLS/www/lua/test_sql2.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/nixio/axTLS/www/lua/test_sql2.lua')
-rw-r--r--libs/nixio/axTLS/www/lua/test_sql2.lua24
1 files changed, 0 insertions, 24 deletions
diff --git a/libs/nixio/axTLS/www/lua/test_sql2.lua b/libs/nixio/axTLS/www/lua/test_sql2.lua
deleted file mode 100644
index a2f6ee12dc..0000000000
--- a/libs/nixio/axTLS/www/lua/test_sql2.lua
+++ /dev/null
@@ -1,24 +0,0 @@
-require"postgres"
-
-local env = assert (luasql.postgres ())
-local conn = assert (env:connect ("luasql-test", "tomas"))
-local cur = assert (conn:execute ("select count(*) from t1"))
-local total = tonumber (cur:fetch())
-cur:close()
-local aleatorio = math.random(total)
-local cur = assert (conn:execute ("select * from t1, t2 where b = d and a != "..2*aleatorio))
-
-cgilua.htmlheader()
-cgilua.put ("Aleatorio = "..aleatorio.."<br>\n")
-
-local a,b,c,d = cur:fetch()
-cgilua.put ("<table>\n")
-while a do
--- cgilua.put ("<tr><td>",a,"<td>",b,"<td>",c,"<td>",d,"</tr>")
- a,b,c,d = cur:fetch()
-end
-cgilua.put ("</table>\n")
-
-cur:close()
-conn:close()
-env:close()