summaryrefslogtreecommitdiffhomepage
path: root/libs/nixio/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-05-28 13:50:00 +0000
committerSteven Barth <steven@midlink.org>2009-05-28 13:50:00 +0000
commit20d2e99010f067cd45a7bcfa93fe10862882b3a8 (patch)
treecbd1efa9828a6b1f3fa35a08746c9378477f30c7 /libs/nixio/Makefile
parentd0bb8964dd9690d7b3ae423c598e95f7fb81ae99 (diff)
nixio: Rework TLS support, added support for CyaSSL
Diffstat (limited to 'libs/nixio/Makefile')
-rw-r--r--libs/nixio/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/libs/nixio/Makefile b/libs/nixio/Makefile
index 8e87eaa10..500b6c4f1 100644
--- a/libs/nixio/Makefile
+++ b/libs/nixio/Makefile
@@ -28,6 +28,13 @@ ifeq ($(NIXIO_TLS),openssl)
NIXIO_LDFLAGS += -lssl
endif
+ifeq ($(NIXIO_TLS),cyassl)
+ NIXIO_LDFLAGS += -lcyassl
+ TLS_DEPENDS = src/cyassl-compat.o
+ TLS_CFLAGS = -include src/cyassl-compat.h
+ NIXIO_OBJ += src/cyassl-compat.o
+endif
+
ifeq ($(OS),SunOS)
NIXIO_LDFLAGS += -lsocket -lnsl -lsendfile